Technical Staff Blog

Last update on .

We have upgraded the FastX cluster from version 2 to version 3. We hope that this will resolve most or all of the issues FastX users have been experiencing over the last few weeks.

IMPORTANT: To use FastX 3, you will need to download the FastX version 3 client from software.brown.edu. Versions 2 and 3 are incompatible, so the old client software will no longer work. The setup process is the same, and the instructions may be found at https://cs.brown.edu/about/system/connecting/fastx/.

Send questions or reports of persisting issues to problem@cs.brown.edu.